1С справочник картинка

Как загрузить картинки в 1С (или выгрузить)

Обработка для массовой загрузки и выгрузки картинок номенклатуры (загрузка в карточку номенклатуры из произвольного каталога или сайта и выгрузка в произвольный каталог).

Если нам нужно загрузить картинки из папки на диске, то заполняем первую закладку Загрузка в базу:

Выбираем папку и вариант поиска номенклатуры в программе (на скрине показано настройка, при которой в названии файлов картинок есть код справочника номенклатуры, и мы карточки тоже ищем по коду. Так же можно искать по артикулу или наименованию номенклатуры. Нужный вариант выбирайте, исходя из того, какая информация у вас в названии файлов картинок). В выбранной папке обработка будет искать файлы с расширением PNG, JPG, BMP и GIF. Для загрузки картинок нажимаем Загрузить картинки, по окончании процесса появится протокол:

Для выгрузки картинок из базы воспользуемся второй закладкой Выгрузка на диск:

Здесь также выбираем папку для сохранения файлов и вариант именования картинок: по артикулу, коду справочника или наименованию номенклатуры. При необходимости можно настроить отбор по номенклатуре (если интересуют файлы картинок не всей номенклатуры, а по определенному фильтру). После этого нажимаем Выгрузить картинки, по окончании процесса появится протокол выгрузки:

Видим, что картинки успешно появились в папке назначения:

Обновление от 16.02.2018

Добавлена возможность загрузки картинок с сайтов, для этого нужно заполнить таблицу для загрузки. В первой колонке указать номенклатуру (код, артикул или наименование), во второй — адрес картинки.

Обновление от 05.11.2018

Теперь можно загружать произвольное количество картинок для одной номенклатурной карточки, допустим есть такие фотографии:

Будем загружать их в базу. Наименования файлов при этом должны начинаться с артикула/кода/наименования товара, дальше должен быть разделитель (по умолчанию знак подчеркивания), а затем любая произвольная информация.

По окончании появится протокол:

Помимо картинок, можно грузить и прочие файлы по одноименной кнопке (pdf, word, excel, xml):

Теперь можем посмотреть загруженные файлы из товарной карточки:

Помимо выгрузки прикрепленных файлов номенклатуры теперь можно помечать их на удаление (не забудьте затем удалить помеченные файлы используя типовые средства 1С):

Работа с хранилищем значений в 1Cv8

В хранилище значения можно сохранить почти любую информацию, например,

… картинки (фотки):

…табличный документ:

<source lang=1c> Процедура СохранитьВХранилищеНажатие(Элемент)

ТабДок=Новый ТабличныйДокумент; ТабДок.Вывести(ЭлементыФормы.ПолеТабличногоДокумента1); Хранилище=Новый ХранилищеЗначения(ТабДок); Записать();

КонецПроцедуры

Процедура ВосстановитьИзХранилищаНажатие(Элемент)

ТабДок=Хранилище.Получить(); Если ТабДок<>Неопределено Тогда ЭлементыФормы.ПолеТабличногоДокумента1.Вывести(ТабДок); КонецЕсли;

КонецПроцедуры </source>

… произвольные файлы (двоичные данные):

<source lang=1c> ХЗ = Новый ХранилищеЗначения(Новый ДвоичныеДанные(файл)); </source>

Восьмерка поддерживает сжатие данных, помещаемых в хранилище:

<source lang=1c> ХЗ = Новый ХранилищеЗначения(Новый ДвоичныеДанные(файл),Новый СжатиеДанных(9)); </source>

… внешние обработки и отчеты:

<source lang=1c> Процедура ЗагрузитьОбработкуВХранилище(РеквизитТипХранилище)

СтепеньСжатия = Новый СжатиеДанных(9); //9 максимум РеквизитТипХранилище = Новый ХранилищеЗначения(Новый ДвоичныеДанные(«c:\отчеты\отчет.epf», СтепеньСжатия));

КонецПроцедуры

Процедура ЗапуститьОбработкуИзХранилища(РеквизитТипХранилище)

ИмяВременногоФайла = КаталогВременныхФайлов()+»отчет.epf»; ДвоичныеДанные = РеквизитТипХранилище.Получить(); ДвоичныеДанные.Записать(ИмяВременногоФайла); ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяВременногоФайла); ВнешняяОбработка.ПолучитьФорму().Открыть();

КонецПроцедуры </source>

Работа с хранилищем

Если это были ДвоичныеДанные, то их можно восстановить из хранилища значения методом Получить и записать в файл методом Записать().

<source lang=1c> Если ТипЗнч(Хранилище) <> Тип(«ДвоичныеДанные») Тогда

ДвоичныеДанные = Хранилище.Получить();

Иначе

ДвоичныеДанные = Хранилище;

КонецЕсли; ДвоичныеДанные.Записать(ИмяФайла); </source>

Если это был, например, Word-документ (doc-файл, или другой файл зарегистрированного типа), то его можно открыть так:

<source lang=1c> ЗапуститьПриложение(ИмяФайла); </source>

Чтобы очистить поле типа Хранилище значения, нужно присвоить ему Неопределено:

<source lang=1c> РеквизитХранилище = Неопределено; </source>

Работа с файлами и картинками во встроенном языке 1С:Предприятия 8

Назначение

В управляемом приложении реализован новый механизм работы с файлами. Он обеспечивает обмен файлами между информационной базой и клиентским приложением. Особенностью данного механизма является то, что он ориентирован на использование в тонком клиенте и Веб-клиенте и разработан с учетом ограничений на работу с файлами, накладываемыми веб-браузерами.

Механизм представляет собой набор методов, с помощью которых можно поместить данные, хранящиеся локально у пользователя, во временное хранилище информационной базы, перенести эту информацию из временного хранилища в базу данных и получить ее обратно на компьютер пользователя. Наиболее распространенные прикладные задачи, решаемые этим механизмом, – это хранение сопроводительной информации, например, изображений товаров, связанных с договорами документов и т. п.

Область действия методов

Временное хранилище

Временное хранилище — это специализированная область информационной базы, в которую могут быть помещены двоичные данные. Основное назначение – это временное хранение информации при клиент-серверном взаимодействии до ее переноса в базу данных.

Необходимость во временном хранилище возникает из-за того, то в модели работы веб-браузера требуется передать выбранный пользователем файл непосредственно на сервер без возможности его хранения на клиенте. При передаче файла он помещается во временное хранилище и уже потом может быть использован при записи объекта в базу данных.

Наиболее типичная решаемая временным хранилищем прикладная задача – обеспечение доступа к файлам или картинкам до того, как объект будет записан в информационную базу, например, в форме элемента.

Файл или двоичные данные, помещенные в хранилище, идентифицируются уникальным адресом, который в дальнейшем можно использовать в операциях записи, чтения или удаления. Этот адрес выдают методы записи файла во временное хранилище. Отдельный метод во встроенном языке позволяет определить, является ли переданный адрес адресом, указывающим на данные во временном хранилище.

Информационная база

Механизм позволяет получить доступ к двоичным данным, хранящимся в реквизитах типа ХранилищеЗначений.

Как и в случае временного хранилища, доступ к информации возможен через специальный адрес. Получить его можно через специальный метод, передав ссылку на объект или ключ записи регистра сведений, и имя реквизита. В случае табличной части дополнительно требуется передать и индекс строки табличной части.

Методы работы с файлами имеют ограничение при работе с реквизитами информационной базы. Для них, в отличие от временного хранилища, доступно только чтение информации, но не ее запись или удаление.

Описание методов работы с файлами

Сохранение данных во временное хранилище

Наиболее типичный сценарий использования данного механизма предусматривает первоначальное размещение данных пользователя во временное хранилище. Для этого предназначены два метода: ПоместитьФайл() и ПоместитьФайлВоВременноеХранилище().

Первый метод, ПоместитьФайл(), помещает файл из локальной файловой системы во временное хранилище. Метод может принимать целевой адрес в хранилище. Если же он не определен или является пустой строкой, то будет создан новый файл и метод вернет его адрес через соответствующий параметр.

Если параметр, определяющий интерактивный режим работы, равен Истина, то метод отобразит стандартное диалоговое окно выбора файла, в котором можно выбрать файл для помещения в хранилище. В этом случае метод также вернет адрес выбранного файла.

Как результат метод возвращает Ложь, если пользователь в интерактивном режиме отказался от совершения операции в диалоге выбора файла. Метод доступен только на клиенте.

Второй метод, ПоместитьФайлВоВременноеХранилище(), схож с предыдущим, за исключением того, что он доступен на сервере, а данные для записи во временное хранилище представляются не в виде пути в файловой системе, а в виде переменной типа ДвоичныеДанные. Точно так же, если не указан целевой адрес, создается новый файл в хранилище. Его адрес возвращается как результат функции.

Получение файла из временного хранилища

При записи объекта в информационную базу может понадобиться извлечь данные из временного хранилища и поместить их, например, в реквизит. Для этого есть соответствующий серверный метод — ПолучитьФайлИзВременногоХранилища(). Этот метод извлекает данные из временного хранилища и возвращает их как результат. Для этого необходимо указать адрес во временном хранилище. Этот адрес возвращают вышеописанные методы ПоместитьФайл() и ПоместитьФайлВоВременноеХранилище() в случае их успешного выполнения.

Удаление файла из временного хранилища

После того, как данные сохранены в реквизите, файл во временном хранилище можно удалить. Для этого есть метод УдалитьФайлИзВременногоХранилища(), который удаляет файл из временного хранилища. Метод принимает в параметре адрес файла во временном хранилище. Доступен на сервере.

Проверка адреса на принадлежность временному хранилищу

Адрес файла может указывать как на временное хранилище, так и на реквизит в информационной базе. Для проверки его типа существует метод ЭтоАдресВременногоХранилища().

Он проверяет, что переданный адрес является адресом, указывающим на хранилище. Возвращает Истина, если адрес указывает на временное хранилище. Метод доступен на сервере.

Получение адреса реквизита

После того, как данные помещены в реквизит в информационной базе, может потребоваться получить доступ к ним с помощью файловых методов.

Но прежде чем получить данные, например из реквизита, необходимо получить адрес этого реквизита. Для этого существует метод ПолучитьАдресФайлаВИнформационнойБазе().

Его назначение – вернуть адрес файла в информационной базе по исходным параметрам. Для этого необходимо передать ключ объекта (это может быть как ссылка на объект, так и ключ записи регистра сведений) и имя реквизита. Если нужно получить адрес файла, хранимого в реквизите табличной части, до имени реквизита в параметре, задающем имя реквизита, необходимо добавить имя табличной части и точку «.». Метод доступен как на клиенте, так и на сервере.

Получение файла из информационной базы

Метод ПолучитьФайл() получает файл из информационной базы и сохраняет его в локальную файловую систему пользователя. Первый параметр определяет адрес файла в реквизите или во временном хранилище файлов. Второй параметр определяет целевое расположение полученного файла. В не интерактивном режиме необходимо указать путь. В интерактивном режиме параметр является опциональным.

По умолчанию метод исполняется в интерактивном режиме, то есть последний параметр равен Истина. Это значит, что выдается диалоговое окно, в котором можно указать действие с полученным файлом: запустить его или сохранить по указанному пользователем расположению. Если активен интерактивный режим, а параметр Целевой путь к файлу на диске не указан, то операция открытия файла не доступна. Возвращает булевское значение. Ложь означает, что пользователь выбрал отмену операции в диалоговом окне сохранения файлов в интерактивном режиме.

Пример использования файловых методов

<source lang=1c> // Получение в интерактивном режиме файла с диска // и помещение его во временное хранилище &НаКлиенте Процедура ВыбратьФайлСДискаИЗаписать()

Перем ВыбранноеИмя; Перем АдресВременногоХранилища; Если ПоместитьФайл(АдресВременногоХранилища, ВыбранноеИмя, Истина) Тогда Объект.ИмяФайла = ВыбранноеИмя; ПоместитьФайлОбъекта(АдресВременногоХранилища); КонецЕсли;

КонецПроцедуры

// Копирование файла из временного хранилища в реквизит // справочника, запись объекта,удаление файла из временного // хранилища &НаСервере Процедура ПоместитьФайлОбъекта(АдресВременногоХранилища)

ЭлементСправочника = РеквизитФормыВЗначение(«Объект»); ДвоичныеДанные = ПолучитьФайлИзВременногоХранилища(АдресВременногоХранилища); ЭлементСправочника.ДанныеФайла = Новый ХранилищеЗначения(ДвоичныеДанные); ФайлПутьНаДиске = Новый Файл(ЭлементСправочника.ИмяФайла); ЭлементСправочника.ИмяФайла = ФайлПутьНаДиске.Имя; ЭлементСправочника.Записать(); Модифицированность = Ложь; УдалитьФайлИзВременногоХранилища(АдресВременногоХранилища); ЗначениеВРеквизитФормы(ЭлементСправочника, «Объект»);

КонецПроцедуры

// Считывание файла из реквизита и сохранение его // на локальном диске в интерактивном режиме &НаКлиенте Процедура ПрочитатьФайлИСохранитьНаДиск()

Адрес = ПолучитьАдресФайлаВИнформационнойБазе(Объект.Ссылка, «ДанныеФайла»); ПолучитьФайл(Адрес, Объект.ИмяФайла, Истина);

КонецПроцедуры </source>

Поддержка адресов в поле картинки

Элемент управления Поле картинки поддерживает отображение картинки, заданной адресом файла во временном хранилище или в базе данных.

Для этого в свойстве Данные элемента формы необходимо задать реквизит строкового типа. Значение этого реквизита и будет интерпретироваться как адрес картинки.

Пример <source lang=1c> // Привязка поля картинки к адресу картинки во временном // хранилище. АдресКартинки реквизит формы строкового типа

ПоместитьФайл(АдресКартинки, ,Истина)

Картинка.Данные = АдресКартинки </source>

Ограничения при работе с Веб-клиентом

Работа описываемого механизма при использовании Веб-клиента имеет некоторые ограничения. Эти ограничения связаны с особенностями модели безопасности браузера. Так, например, клиент самостоятельно не может сохранить файл в локальную файловую систему, то есть доступен только интерактивный вариант клиентских методов ПоместитьФайл() и ПолучитьФайл(). При попытке использовать не интерактивный режим генерируется исключение. Диалоговые окна, отображаемые в интерактивном режиме, специфичны для конкретного типа браузера.

Особенности при работе с ХранилищемЗначений на Клиенте

Проблема:

Когда у Документа в табличной части есть реквизит типа ХранилищеЗначений, то тормозит открытие формы документа, если в этом реквизите записаны данные большого размера.

Предполагаемая причина:

Возможно, при открытии формы, на клиент передается не ссылка на данные находящиеся в ХранилищеЗначений, а сами данные.

Решение

  • В свойствах табличного реквизита формы есть флаг «Использовать всегда». Если он установлен, то содержимое поля всегда передается между сервером и клиентом — например, при открытии формы. Этот флаг надо отключить, но при этом нужно учесть это в коде, так как по умолчанию значения этого поля на клиенте не будет. Пример можно посмотреть в 1С:Архив.

Ещё лучше использовать временное хранилище для передачи файлов между клиентом и сервером.

Вывод изображения на управляемую форму

  • Добавить свою публикацию
  • для этого требуется регистрация

YPermitin 23.04.2013 +2

Небольшая задача

В тестовой конфигурации для элементов справочника «Сотрудники» был создан механизм прикрепления файлов изображений. Однако при открытии элемента текущее изображение можно посмотреть лишь открыв прикрепленный файл.

Наша задача будет заключаться в отображении на форме элемента текущего изображения. Главное условие — доработка осуществляется для управляемой формы.

Как это было раньше

Прежде чем перейти к решению задачи, рассмотрим, как это реализовывалось бы для обычной формы. В тестовой конфигурации для справочника «Сотрудники» созданы два реквизита:

  • «Фото» — реквизит с типом «ХранилищеЗначений», в котором хранятся двоичные данные файла изображения.
  • «ИмяФайла» — строковой реквизит, в который записывается имя файла прикрепленного изображения.

На обычной форме добавляется элемент «ФотоСотрудника» с типом «Поле картинки». В событии «ПередОткрытием» формы добавляем следующий код: Процедура ПередОткрытием(Отказ, СтандартнаяОбработка) // Получаем картинку из двоичных данных КартинкаВХранилище = Новый Картинка(Фото.Получить()); // Подставляем картинку в элемент формы ЭлементыФормы.ФотоСотрудника.Картинка = КартинкаВХранилище; КонецПроцедуры

И, вуаля! При открытии отображается прикрепеленной ранее фото!

Вся задача решилась в два шага: добавляем поле картинки на форму, и перед открытием получаем картинку из реквизита элемента справочника и присваиваем элементу формы. С управляемой формой все немного сложнее.

На управляемой форме

На управляемой форме просто так получить картинку из хранилища значений не получится, а уж тем более поместить его на управляемую форму. Поскольку управляемые формы созданы для четкого разделения клиентской и серверной стороны, то и логика работы будет иной.

Для отображения изображения для начала добавим строковой реквизит формы «ФотоСотрудника», для которого на форме создадим элемент с типом «Поле картинки».

Теперь в обработчике формы «ПриСозданииНаСервере» добавим следующий программный код:

&НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) ОбновитьИзображение(); КонецПроцедуры &НаСервере Процедура ОбновитьИзображение() // Конвертируем объект формы в объект справочника, чтобы //можно было работать с реквизитом типа «Хранилище значений» ОбъектЭлемента = РеквизитФормыВЗначение(«Объект»); // Помещаем двоичные данные из реквизита во временное хранилище. //Адрес из хранилища помещаем в строковой реквизит // формы «Фото сотрудника» ФотоСотрудника = ПоместитьВоВременноеХранилище(ОбъектЭлемента.Фото.Получить(), УникальныйИдентификатор); КонецПроцедуры

Здесь методом «ПоместитьВоВременноеХранилище» мы помещаем двоичные данные из реквизита «Фото» элемента справочника во временное хранилище. Метод возвращает адрес помещенных данных во временном хранилище в виде строки. Подробнее о временном хранилище, его назначении и примеров работы с ним Вы можете прочитать по ссылке.

В результате при открытии элемента мы увидим следующее:

На этом задача полностью решена!

Задача решена

Задачу мы решили, но есть куда оптимизировать! Файл лучше вынести в отдельную таблицу, чтобы время открытия элемента справочника не возросло при прикреплении изображений больших размеров. Но оптимизация уже выходит за рамки статьи.

Для удобного переноса изображений в 1С, служит бесплатная утилита «Загрузчик изображений в 1С», которая идет в комплекте утилит EasyControl.

Обработка предназначена для загрузки файлов изображений номенклатуры в типовые конфигурации «1С: Управление Торговлей, редакция 11», «1С: Розница, редакция 2.0», «1С: Управление торговлей, редакция 10.3», «1С: Розница редакция 1.0», «1С: Комплексная автоматизация, редакция 1.1», «1С: Управление производственным предприятием, редакция 1.3».

  1. Необходимо указать каталог, содержащий изображения товаров.
  2. Указать расширение файлов для загрузки (по-умолчанию используется JPG). При этом, если выбрать маску — будет выполнена попытка загрузить все файлы каталога.
  3. Поиск элементов справочника номенклатуры (владельца изображения) происходит по коду или по артикулу номенклатуры. Поэтому, для идентификации номенклатуры необходимо указать:
    реквизит поиска номенклатуры — код/артикул;
    выражение — для получения кода элемента справочника из наименования файла. По-умолчанию считается, что имя файла полностью соответствует коду (артикулу) номенклатуры. Если это не так, то с помощью , используя встроенный язык 1С, можно задать произвольное выражение получения кода (артикула), по которому и происходит поиск номенклатуры.
    Например:
    Имена файлов имеют формат: IMG_0001.jpg, где 0001 — это код номенклатуры.
    Тогда выражение для получения кода будет иметь вид:
    Сред(Файл.ИмяБезРасширения,5).
  4. Указать, какой из найденный файлов будет выводится в карточке товара.
  5. По кнопке Загрузить выполнить импорт изображений. По результатам загрузки будет выведен отчет с перечнем удачно загруженных файлов.

Заметки из Зазеркалья

Поддержка корпоративного стиля

Данная статья является анонсом новой функциональности.
Не рекомендуется использовать содержание данной статьи для освоения новой функциональности.
Полное описание новой функциональности будет приведено в документации к соответствующей версии.
Полный список изменений в новой версии приводится в файле v8Update.htm.

Реализовано в версии 8.3.13.1513.

Благодаря тому, что в основе всех прикладных решений 1С:Предприятия находится платформа, прикладные решения имеют однотипный интерфейс, они привычны для пользователей и выглядят узнаваемо. В то же время на крупных внедрениях такая узнаваемость может являться недостатком, если вместе с 1С:Предприятием заказчик использует сторонние программные продукты, выполненные в другой палитре или в определенном корпоративном стиле, принятом в компании.

Поэтому в версии 8.3.13 мы решили сделать несколько доработок, которые позволят вам подстроить внешний вид прикладного решения под эстетические требования заказчика, под тот стиль, который используется в большинстве его программных продуктов.

Такая возможность, безусловно, будет полезна вам при внедрении корпоративных типовых решений, потому что позволит учесть корпоративный стиль заказчика.

Также эта возможность будет полезна для нетиповых решений, тесно интегрированных со сторонними продуктами заказчика. Например, когда глобальная навигация реализована в стороннем приложении, а 1С:Предприятие должно запускаться в нужные моменты и сразу переходить на требуемую точку навигации. При этом очень желательно, чтобы запуск происходил без заставки и стартовых диалогов, а само 1С:Предприятие было бы похоже на то стороннее приложение, из которого оно запускается.

Основной стиль в управляемом приложении

Все изменения, о которых пойдёт речь, мы реализовали с помощью хорошо известных вам объектов конфигурации Стиль. Они существовали в прошлых версиях платформы, они использовались в обычном приложении. Но с появлением управляемого приложения и интерфейса Такси, необходимость в этих объектах, как в инструменте «раскрашивания» интерфейса исчезла. И сейчас мы возвращаем лишь некоторые их возможности.

Во-первых, мы вернули свойство конфигурации ОсновнойСтиль. То есть вы можете указать, какой из имеющихся стилей является основным для вашего прикладного решения.

Естественно, мы вернули и сами объекты конфигурации Стиль. Теперь вы можете видеть их в дереве конфигурации. Однако в управляемом приложении вам будет доступна настройка только пяти стилевых цветов, которые используются в интерфейсе Такси:

  • Цвет навигации устанавливает цвет фона панели разделов;
  • Цвет дополнительной навигации устанавливает цвет фона панели функций текущего раздела;
  • Цвет активности применяется к следующим элементам интерфейса:
    • рамка текущего элемента формы,
    • фон текущего элемента меню,
    • фон текущей строки и ячейки таблицы;
  • Цвет важного устанавливает цвет фона кнопки по умолчанию;
  • Цвет акцентирования применяется к следующим элементам интерфейса:
    • текст заголовка группы,
    • отметка флажка, переключателя и полосы регулирования,
    • индикатор текущей формы в панели открытых.

Для облегчения вашей работы платформа берёт на себя некоторые дополнительные действия, связанные с выбранными вами цветами. Например, если для фона вы выбираете достаточно тёмный цвет, то платформа самостоятельно инвертирует цвет текста так, чтобы он хорошо читался на этом фоне. Кроме этого часть цветов платформа рассчитывает от стилевых (выбранных вами), например цвет рамки кнопок, цвет текущей строки неактивной таблицы и тому подобное.

Кроме непосредственного указания основного стиля в Конфигураторе, вы можете сделать это и с помощью встроенного языка. В контекст управляемого приложения мы вернули свойство глобального контекста ГлавныйСтиль. Устанавливать это свойство вам нужно в обработчике события УстановкаПараметровСеанса().

Основной стиль в мобильном клиенте

Аналогичные изменения мы выполнили и в мобильном клиенте. Однако из-за специфики мобильного интерфейса в нём используется меньшее количество стилевых цветов:

  • Цвет активности применяется к следующим элементам интерфейса:
    • фон заголовка формы,
    • фон текущего элемента меню,
    • фон текущей строки и ячейки таблицы,
    • индикатор,
    • иконки рабочего стола;
  • Цвет акцентирования применяется к следующим элементам интерфейса:
    • текст заголовка выбранной страницы,
    • отметка флажка, переключателя и полосы регулирования,
    • фон кнопок;
  • Кроме этого при работе в операционной системе Android цвет акцентирования применяется:
    • к полосе в поле ввода в режиме редактирования,
    • к полоскам на барабане при выборе даты;

Цвет навигации, цвет дополнительной навигации и цвет важного в мобильном клиенте не используются.

Так же, как и в «обычных» клиентских приложениях, платформа автоматически адаптирует цвет текста под цвет фона (на светлом фоне черный цвет, на темном фоне белый текст). Кроме этого фон кнопок контекстного меню строки таблицы рассчитывается исходя из выбранного вами цвета активности.

Отключение заставки при запуске

Как мы уже упоминали в начале, на крупных внедрениях с тесной интеграцией возникает потребность запускать прикладные решения 1С:Предприятия без заставки и стартовых диалогов. Возможность отключать стартовые диалоги и сообщения существует давно, для этого используются параметры командной строки DisableStartupDialogs и DisableStartupMessages.

Теперь мы добавили к ним ещё один параметр – DisableSplash. На корпоративных внедрениях этот параметр позволяет не показывать при запуске собственную заставку 1С:Предприятия, замена которой была согласована с фирмой 1С.

Расширение стилей и картинок

Возможность изменения стиля приложения мы вынесли и в расширения. То есть, применяя то или другое расширение, вы тоже можете менять стиль прикладного решения, не меняя саму конфигурацию.

В расширениях вы можете теперь, например, создавать собственные стили, переопределять основной стиль конфигурации, а также заимствовать и переопределять стили конфигурации.

Кроме этого в расширении вы можете переопределять свойства конфигурации, содержащие картинки. Это такие свойства, как:

  • Картинка основного раздела;
  • Логотип;
  • Заставка.

При этом происходит полное замещение картинки, то есть используется только картинка из расширения. Если одно и то же свойство переопределяют сразу несколько расширений, то в результате будет использоваться картинка из расширения, применённого последним.

Брендирование расширений

Применительно к расширениям хочется сказать ещё об одной новой возможности. Она не связана непосредственно со стилем прикладного решения, но позволяет вам обозначить авторство своего расширения, и дать ссылки на подробную информацию, связанную с ним.

Непосредственно в расширение конфигурации мы добавили поля с информацией о поставщике и о самом расширении:

  • Краткая информация;
  • Подробная информация;
  • Авторские права;
  • Адрес информации о поставщике;
  • Адрес информации о конфигурации.

Эти поля имеют то же назначение, что и одноимённые свойства конфигурации, но описывают расширение. Информация из этих полей отображается в окне О программе для каждого из установленных расширений. Например, так:

Мы надеемся, что новые возможности помогут вам осуществлять более качественные внедрения, и адаптировать внешний вид приложений к корпоративным стилям.

Рассказать друзьям: